WordPress Backward Compatibility Poll

This is a poll to help us understand your needs regarding WordPress backward compatibility.

Here’s why:

We are considering to change the minimum system requirements, and require a minimum WordPress version of 3.3. This is in order to utilize the new WordPress API’s not available with older versions – like the help API used to add help tabs to the Smart Sliding Notes option page.

Right now, features that depend on WP 3.3 are simply disabled or excluded for older versions. In order to keep the code lean and snappy, we’d like to remove backward compatibility branches by explicitly requiring WP 3.3 or newer. We reckon this shouldn’t be a big deal, as keeping WordPress up to date is first and foremost a matter of website security, but we’d like to hear your voice on this first.

Please participate in this poll:

Do you need backward compatibility with WordPress versions older than 3.3?

  • No, my sites are always up to date when it comes to WordPress (100%, 1 Votes)
  • Yes, I need compatibility with WP 3.2 (0%, 0 Votes)
  • Yes, I need compatibility with WP 3.1 (0%, 0 Votes)
  • Yes, I need compatibility with WP 3.0 (0%, 0 Votes)

Total Voters: 1

Loading ... Loading ...

No comments yet... Be the first to leave a reply!

Leave a Reply